Ярлык сетевого адаптера и RegOrganizer

Вопросы и предложения по программам Reg Organizer, Registry Life и Autorun Organizer
MensuraZoili
Сообщения: 9
Зарегистрирован: Чт сен 10, 2015 10:10 am

Ярлык сетевого адаптера и RegOrganizer

Сообщение MensuraZoili » Чт сен 10, 2015 11:02 am

Доброго времени суток!
Такая у меня приключилась история. Ничего непоправимого, но не понятно. Система Win-10, официальный апгрейд через Центр обновления Windows с лицензионной Windows-8.1. RegOrganizer стоял еще на 8.1 так и обновилось все до 10-ки вместе с ним. Версию на 10-ке обновлял, так что можно считать (наверное), что RegOrganizer переустановлен. На рабочем столе, у меня был выведен ярлык сетевого адаптера из вкладки "Изменение параметров адаптера" панели упраления Windows.

Поставил себе на комп TeamWiever 10. Через пару дней словил глюк с доступностью сети. Значок сети в трее то показывал отсутсвие подключения (красный кружок), потом мгновенно сменялось на ограниченное подключение (желтый тругольник), затем на мгновение появлялся доступ к сети и снова отсутсвие подключения, и т.д. Через некоторое время, попытки инциализироваться прекращались и сеть отваливалась совсем.

Первое, что решил сделать - программно отключить-включить адаптер. Щелкаю на ярлык адаптера, а получаю запрос UAC на запуск RegOrganizer. Удаляю ярлык, перетягиваю значок адаптера из панели упрвления на рабочий стол, создавая таким образом новый ярлык, запускаю... Снова UAC с запросом на запуск RegOrganizer. Щас уже и не помню, что делал, но после некоторого времени танцев с бубнами и перезагрузок сеть заработала, и только после этого, ярлык созданный с уже корректно работающего сетевого адаптера, стал опять открывать его свойства, а не RegOrganizer. Пока доступость сети не восстановилась, ярлык пытался упрямо запускать RegOrganizer.
Сегодня, опять пошла свистопляска с доступностью к сети и я удалил TeamWiever с помощью RegOrganizer, естетсвенно. После удаления, запускаю корректно работавший до сего момента ярлык сетевого адаптера, но снова получаю запрос UAC на запуск RegOrganizer. Удаляю ярлык в корзину, вывожу новый - все работает. Прячу новый ярлык в папку на рабочем столе, восстанавливаю из корзины удаленный - он тоже работает нормально.

Не понятно, с чем может быть связано такое настойчивое обращение ярлыка сетевого адаптера к Вашей программе? Может ли тут быть связь с CLSID и не требует ли данная ситуация Вашего внимания, уважаемые разработчики? Может, все это полная ерунда, а может - верхушка айсберга, это можете сказать только Вы.

Аватара пользователя
Chemtable Software
Команда разработчиков
Сообщения: 1424
Зарегистрирован: Пн сен 23, 2002 10:22 pm

Re: Ярлык сетевого адаптера и RegOrganizer

Сообщение Chemtable Software » Чт сен 10, 2015 4:13 pm

Здравствуйте.

Возможно, проявляется какой-то глюк системы, связанный с тем, что Reg Organizer добавляет в контекстное меню ярлыков команду для удаления программы. В следующий раз, если проблема возникнет, попробуйте отключить добавление команды, сняв галочку, показанную на картинке. Если это повлияет на проблему, будет понятно из-за чего проблема.

2015-09-10 18-10-59 Настройки.png
2015-09-10 18-10-59 Настройки.png (42.35 КБ) 2811 просмотров

Ответить