Autorun Organizer: adding .ahk file issue

Questions and comments regarding Reg Organizer, Registry Life and Autorun Organizer.
User avatar
Meddly
Posts: 2
Joined: Mon May 27, 2019 9:24 am

Autorun Organizer: adding .ahk file issue

Post by Meddly » Mon May 27, 2019 10:08 am

Thank you for the excellent Autorun Organizer!

Trying to add an .ahk file (AutoHotkey script) to startup. My 2 PCs:

PC1: recently upgraded from Windows 10 x64 1809 to 1903. File is added successfully (tried both HKEY_CU/LM) but when Autorun Organizer tries to launch it at startup (with or without delay) I get the Windows 10 prompt/list "How to you want to open this file? with a bunch of programs available, except AutoHotkey. I close the prompt with Esc and the file is not executed. .ahk files are properly registered and when I double-click one, AutoHotkey.exe is launched in the background as it should.

Also, something unusual on this PC: AO keeps launching my delayed entries even before I've logged in. So, if I wait 1-2 minutes before entering my Windows password and then log in, everything is already launched. Is this to be expected?

PC2: clean 1903 x64 install: items are launched only after I've logged in, which seems the norm. The AutoHotkey issue also occurred at first, but after a few retries it works and is now properly launched with a delay (HKEY_LM worked, HKEY_CU didn't).

User avatar
Meddly
Posts: 2
Joined: Mon May 27, 2019 9:24 am

Re: Autorun Organizer: adding .ahk file issue

Post by Meddly » Wed May 29, 2019 11:36 am

Found a workaround for the .ahk issue: created a shortcut for it in the Start Menu\Programs\StartUp folder. AO picks it up from there, and it is properly launched and delayed.

I clean-installed 1903 on PC1, too. AO still launches the programs before the user logs in. This does not happen on the other PC so I'm not sure what's the intended behaviour.

User avatar
Chemtable Software
Developers Team
Posts: 340
Joined: Thu Aug 07, 2008 12:59 pm

Re: Autorun Organizer: adding .ahk file issue

Post by Chemtable Software » Tue Jun 04, 2019 11:08 am

Hello,

Thank you for interesting in our product.

Regarding the entries launched before logging. This is correct behavior because this is the way the Task Manager which is used to provide the delayed load functionality is executing a task.

Post Reply